devel/aprのエラー

Apache22のパッチをインストールして再起動しようとしたら、次のエラーが出た。

aprパッケージを再インストールすれば良いとのこと。

apr再ビルド&インストール後、無事にApacheが再起動できた。

portsのaprパッケージには、libaprutilを新しくビルドしたlibaprではなくインストール済みのlibaprにリンクしてしまう不具合があるため、aprをアップデートするときには2回インストールしないといけないらしい。

cf. 「portmaster/mod_security FreeBSD-9.2」 (FreeBSD Forums)、「After apr update, svn can’t find libaprutil-1.so.5」 (freebasd-ports ML)